Rank Tracking Optimization – Focus on Top 50 Results
Date: October 2025
Summary We’ve improved how XOVI tracks rankings and visibility to keep your reports consistent and accurate after recent Google search changes.
What changed - Rank Tracking: Now focused on the Top 50 results, updated daily at the same frequency - Visibility data: Cleaner and more stable trends for better accuracy - Performance Optimization: Inactive or unused projects are updated less often to keep tracking fast and efficient
Why we made this change Google no longer provides extended 100-result SERPs, which affected all SEO tools. By focusing on the Top 50, XOVI ensures stable, meaningful visibility data — where most traffic and competition actually occur. While others reduced result depth or raised prices, XOVI maintained full tracking performance and pricing.
Impact on your data - You may notice small shifts in long-tail rankings - Core visibility and performance trends remain consistent - No action required from your side
Rollout Schedule The new Top 50 tracking will roll out by mid-November 2025 to all users.
Next steps We’re testing an optional Top 100 add-on for agencies that need extended tracking depth. More details coming soon.
Takeaway No data loss: just cleaner, faster, and more consistent ranking insights.
Posted Oct 21, 2025 - 13:09 UTC
Identified
2025-09-14
What happened?
Since September 13/14, Google no longer supports the parameter num=100, which previously allowed retrieving the first 100 organic results of a search. From now on, even if set, Google only delivers the top 10 results. This affects all SEO tools that rely on bulk SERP collection.
Impact on XOVI
Our rank tracking also used this method to capture results beyond the first page. At the moment, only the first 10 results are recorded. This may cause a visible drop in the number of tracked keywords and rankings marked as lost. Importantly, this does not affect your actual traffic or your top 10/20 visibility.
Our approach
- We are adapting our crawling to restore deeper result sets. - This requires extra work, but your core reports and ranking insights will remain consistent where it matters most. - Updates will be posted here as improvements go live.
What you should do
- Annotate Google Search Console (GSC) data from September 10, 2025 onward. - Expect impressions to appear lower going forward, this is due to Google reporting changes, not a real loss of visibility. - Focus on clicks, conversions, and your top rankings as the most reliable KPIs.
Your rankings and traffic have not disappeared! Only the way Google reports them has changed.
Posted Sep 19, 2025 - 13:28 UTC
This incident affected: Keywords and Rank Tracker.